Exchange 2019 installation Failed hybrid environment

jennylee 86 Reputation points
2022-11-04T01:09:20.777+00:00

I have an on-prem exch 2016 hybrid (on server 2012 r2 standard). All mailboxes are on O365. I'm setting up a new exch 2019 (server 2019 standard) so I can then get rid of 2016. It gets stuck on Step 8/12 Mailbox service. The system mailboxes are all there, but the homeMDB attribute, has the 2016 server DB in it.

Do I need to change it?

It appears every time I try to reinstall it, that it creates another DB.

I ran all the initial setups:

\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareSchema

,\setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD /OrganizationName

.\Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAllDomains

Any ideas?

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,494 questions
Microsoft Exchange Hybrid Management
Microsoft Exchange Hybrid Management
Microsoft Exchange: Microsoft messaging and collaboration software.Hybrid Management: Organizing, handling, directing or controlling hybrid deployments.
1,995 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
20,573 questions
0 comments No comments
{count} votes

Accepted answer
  1. Amit Singh 4,876 Reputation points
    2022-11-04T07:28:48.43+00:00

    In my research, it may be related to the discovery system mailbox. So please check if it exists in "Users" OU.
    If existing, please check the attribute "homeMDB", and ensure that it has a valid value the same as another system mailbox.

    Or run "Get-Mailbox -Filter { RecipientTypeDetails -eq "DiscoveryMailbox"} | fl name, database" to see if it returns any error.

    If anything is wrong, you could try to delete this system database and recreate it by running "Setup.exe /IAcceptExchangeServerLicenseTerms /PrepareAD", then re-run the setup wizard and check if the issue persists.
    You could refer to this similar case and this blog, Setup a New Exchange 2019 Server.

    0 comments No comments

5 additional answers

Sort by: Most helpful
  1. Pahan Mandara 0 Reputation points
    2024-04-25T10:06:23.6333333+00:00

    Does Anyone know how to fix this issue? 😢Screenshot 2024-04-25 153550

    0 comments No comments