Update-Help failed with an error message

Gurudas 886 Reputation points
2022-11-06T06:56:13.387+00:00

Hello Team,

I have Powershell version 7.3.0 (Windows 11) and getting below error message while updating Powershell help file via Update-Help command in open internet.

Command : Add-AppxPackage Path:https://go.microsoft.com/fwlink/?LinkID=107116
Error Message: Deployment operation in progress: https://go.microsoft.com/fwli. initialized.
Please suggest.

Get-Help: Get-Help could not find Add-AppxPackage in a help file in this session. To download updated help topics type: "Update-Help". To get help online, search for the help topic in the TechNet library at https://go.microsoft.com/fwlink/?LinkID=107116

Your help will be much appreciated! Have a great weekend.

Windows Server PowerShell
Windows Server PowerShell
Windows Server: A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.PowerShell: A family of Microsoft task automation and configuration management frameworks consisting of a command-line shell and associated scripting language.
5,455 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Gurudas 886 Reputation points
    2022-11-10T10:41:00.02+00:00

    Hello Team,

    I have gone through an article that says the module which is failing needs to be uninstalled and also rename the folder. Then we need to reinstall the module and try updating help module.

    Reference URL: https://devblogs.microsoft.com/powershell/updating-help-for-the-psreadline-module-in-windows-powershell-5-1/

    Will below steps resolve my issue.

    Open an elevated powershell.exe session (Run as Administrator).

    Run Remove-Module OneDrive to remove the auto-loaded OneDrive module.

    Run Import-Module OneDrive

    Then run Update-Help -Module OneDrive -Force

    Have a great day ahead!

    0 comments No comments

  2. Gurudas 886 Reputation points
    2022-11-27T05:53:00.753+00:00

    Hello Team,

    I would like to run following powershell and getting an error that since I am not able to update the help files I wont be able to get all powershell commands available in Office 365 module in one go.

    get-command | get-help -full >>c:\Powershell\office365.csv

    I tried Update-Help -Module OneDrive -Force and Update-Help -UICulture en-US commands but powershell help module is not getting updated.

    Your help and support will be highly appreciated.


  3. Gurudas 886 Reputation points
    2022-12-02T04:45:01.347+00:00

    Hello Team,

    I ran below command and issue got resolved.

    winget install --id Microsoft.Powershell --source winget
    winget install --id Microsoft.Powershell.Preview --source winget

    Reference URL: https://learn.microsoft.com/en-us/powershell/scripting/install/installing-powershell-on-windows?view=powershell-7.3#winget

    Have a great weekend ahead!

    0 comments No comments