In AVD, I can assign users resources, but they are unable to sing into them... why would that be?

Chris Pappas 6 Reputation points
2022-11-11T16:41:23.217+00:00

In Azure I have assigned users in AAD resources, and put them in the correct groups - the users can see the resources such as Azure Virtual Desktop in the initially login from here (https://client.wvd.microsoft.com/arm/webclient/index.html) then when the user opens the resource (in this case the AVD), they are unable to log in saying username is wrong - I have tested this multiple times and the password is 100% correct.
The account that I used to create this (which is in the same group as the example of the user above) can access the resource fine with no issues, so I know it works.
Have turned off MFA defaults too.
Please could someone shed some light.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,439 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Chris Pappas 6 Reputation points
    2022-11-11T17:11:30.947+00:00

    In addition to above - I have tried creating new users, made them global admins, and subscriptions (to mirror the user that has access to these resource) - but I'm still not getting anywhere. Also this is in a sandbox environment which I'm using to play around with...

    1 person found this answer helpful.
    0 comments No comments

  2. Michael Durkan 12,196 Reputation points MVP
    2022-11-11T20:45:23.79+00:00

    Hi

    check your Connection Information under RDP Properties for the Host Pool is set as per screenshot below for Azure AD Authentication:

    259639-image.png

    Hope this helps,

    Thanks

    Michael Durkan

    • If the reply was helpful please upvote and/or accept as answer as this helps others in the community with similar questions. Thanks!
    1 person found this answer helpful.
    0 comments No comments

  3. Hamid 1 Reputation point
    2023-01-07T16:29:42.957+00:00

    Hi,

    If this is an Azure AD joined AVD you might need to add the following RDP property to the hostpool configuration: targetisaadjoined:i:1

    0 comments No comments