Access denied error move-csuser from SFB 2015 to Teams

Roland Taschler 1 Reputation point
2022-11-14T13:05:19.647+00:00

We are currently preparing to switch from Skype For Business to Teams. In our test phase, we have already moved several users from Skype to Teams.
We did the first tests a few months ago and everything went well. When we tried to migrate more test users 3 weeks ago, we got the message in the Skype for Business Powershell that we needed a newer version.
After research, we then installed CU12 HF2 for SFB from Feb 2022 and started the test again. As a result, we received an Access Denied in the SFB Management Shell. We should try other credentials or request access.

We tried this with various admin users, all had the same problem. The move before was also done with the same admin users, at that time it worked perfectly. After some research we found an article that says that with this access denied command just use the -UseLegacyMode option. We did that and it worked. We successfully migrated 70 more users. Unfortunately, this command no longer works since November 7th. and we receive error messages with an error code 524, which unfortunately does not deliver any results even with internet searches.
Environement: Windows 2012 R2 + SFB 2015 Cu12 Hf2

Attached are the messages when trying to migrate users

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12
Move-CsUser -Identity XXXX@YYYY.com -Target sipfed.online.lync.com -Credential $cred -HostedMigrationOverrideUrl $url

Result:
Move-CsUser : {"code":"Forbidden","message":"Access Denied.","action":"Providedifferent credential or request access."} At line:1 char:1 + Move-CsUser -Identity xxxx@yyyy.com -Target sipfed.on ...

Doing some deeper investigation with Fidler we get a 403 Forbidden trying to access https://api.interfaces.records.teams.microsoft.com/HostedMigration/ValidateUser HTTP/1.1

Microsoft support told us to disable TLS 1.0 and 1.1 and enable only TLS 1.2. We did this as statet in relative KB but without success.

Microsoft Teams
Microsoft Teams
A Microsoft customizable chat-based workspace.
9,607 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Roland Taschler 1 Reputation point
    2022-11-16T10:16:40.557+00:00

    Good news.

    I don't know if MS has changed something in Background, but today the command move-csuser startet working as normal. we were able to move a couple of users to Teams without any issues. using the same command as yesterday on the same Server as yesterday.

    Nothing has changed on our site. No Updates, No Reg Changes, no Reboot. Yesterday afternoon the same command returned the Error as stated above, and this morning everything worked without issues.