Deepstream6.1 on Azure VM (Ubuntu 18.04 / 20.4)

Rahul Soundrarajan 1 Reputation point
2022-11-15T12:56:20.917+00:00

Hi,
Can you please suggest the correct VM (with GPU) configuration for setting up DeepStream6.1 on Microsoft Azure?
I have tried with the VM"
NVIDIA GPU-Optimized VMI with vGPU driver" available in Azure that has the following configuration:
---
Ubuntu Server 20.04
NVIDIA GRID Driver
Docker-ce
NVIDIA Container Toolkit
Azure CLI, NGC CLI
Miniconda, JupyterLab, Git
---
I followed the procedure in Quickstart Guide — DeepStream 6.1.1 Release documentation

Execution of sample scripts fail with the below error:

deepstream-app -c source4_1080p_dec_infer-resnet_tracker_sgie_tiled_display_int8.txt
** ERROR: <create_multi_source_bin:1423>: Failed to create element ‘src_bin_muxer’
** ERROR: <create_multi_source_bin:1516>: create_multi_source_bin failed
** ERROR: <create_pipeline:1323>: create_pipeline failed
** ERROR: main:639: Failed to create pipeline
Quitting
App run failed

Note: I repeated the entire procedure with Ubuntu 18.04 which fails with the same error. For 18.04, I followed the steps in this learning path: https://learn.microsoft.com/en-us/training/paths/nvidia-deepstream-development-with-microsoft-azure/

My requirement is to run DeepStream6.1 on Azure VM (Linux distribution).

Thanks.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,513 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. deherman-MSFT 35,241 Reputation points Microsoft Employee
    2022-11-15T17:49:40.947+00:00

    @Rahul Soundrarajan
    I don't believe this error is caused by your VM, but rather an issue with the NVIDIA setup. It looks like it could be caused by an issue with the relative path. Please check these threads and see if you can find a resolution.
    https://forums.developer.nvidia.com/t/failed-to-create-element-src-bin-muxer/65285
    https://forums.developer.nvidia.com/t/deepstream-reference-application-issue-failed-to-create-element-src-bin-muxer/156776

    Hope this helps! If you are still facing issue, I recommend posting your question on the NVIDIA forums as they have a better understanding of the necessary setup process.

    -------------------------------

    Please don’t forget to "Accept the answer" and “up-vote” wherever the information provided helps you, this can be beneficial to other community members.