Why I face the error below when I run the pipeline?

Amirhossein Sorni 21 Reputation points
2022-11-16T14:13:17.95+00:00

When I run a pipeline in Azure DevOps, I face this error:
Cannot import the following key file: globalkey.pfx. The key file may be password protected. To correct this, try to import the certificate again or manually install the certificate to the Strong Name CSP with the following key container name: VS_KEY_xxxxxxxx.

I run the code below in the Developer Command Prompt for VS 2022, and it is successfully done:
sn -i <globalkey.pfx> <VS_KEY_xxxxxxxx>

However, I faced the mentioned error again when I ran the pipeline.

Please help me to find out the solution.

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
37,727 questions
0 comments No comments
{count} votes

Accepted answer
  1. Anonymous
    2022-11-16T14:41:04.52+00:00

    Devops / TFS is not currently supported here on Q&A. The product group for Azure DevOps / TFS actively monitors questions over at
    https://developercommunity.visualstudio.com/report?space=21&entry=problem
    https://developercommunity.visualstudio.com/report?space=22&entry=problem
    https://azure.microsoft.com/en-in/support/devops/

    --please don't forget to upvote and Accept as answer if the reply is helpful--

    0 comments No comments

0 additional answers

Sort by: Most helpful