Azure Container Registry - Missing Several Manifests

CHRISTOS TTINIOZOS 1 Reputation point
2022-11-18T14:10:58.003+00:00

Hi everyone,

I trust you are well!

We are having trouble with a specific repository on our azure container registry.

We have a solution that hosts approximately ~70 different tags, each one corresponding to a specific version of our published solution.

Since today, we have tried to remove some of our tags but we are getting a "Status 404. Not Found" when we try to delete a tag. It looks like the manifest got deleted somehow, resulting in errors when some of our clients are trying to download a certain version, or when we try to delete an old version that we no longer support.

Did anyone happen to come across a similar issue? Please note that we are granting our clients access to download the images by using a security principal that only allows the downloading of an image. Therefore, we highly doubt that this was caused using that security principal credentials.

It is also strange because the faulty tags had previously worked in the past, but their "Tag Creation Date" and "Tag Last Update Date" doesn't point to them being edited anytime recently.

Can someone please help?

Azure Container Registry
Azure Container Registry
An Azure service that provides a registry of Docker and Open Container Initiative images.
426 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. JimmySalian-2011 42,066 Reputation points
    2022-11-19T15:58:06.973+00:00

    Hi,

    Can you check the health of the Container registry via this process listed here. This should provide some info on the issues. If this does not help I can request you to raise a support case.

    Hope this helps.
    JS

    ==
    Please Accept the answer if the information helped you. This will help us and others in the community as well.

    0 comments No comments