Error - The biometric unit could not be configured - Windows Biometric Framework

Lukuta 1 Reputation point
2022-11-18T21:25:00.417+00:00

I have been experimenting with the Windows Biometric Framework in C++. I am trying to use the Private pool to setup a database and enroll fingerprint units and identify them. When I run the setup sample code for client application on the below microsoft links, I am getting a success message but I can't see the private database in WinBioDatabse folder. However, I can see that a database is registered in the registry under the path below

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WbioSrvc\Databases\

Further when I run the enrollment sample code, I am getting the an error error :The biometric unit could not be configured. I am using an inbuilt fingerprint sensor on an HP laptop running Windows 10 OS.
Kindly help with what could be causing this and how to overcome it

private-pool-setup
private-pool-enrollment
private-pool-identity

Windows API - Win32
Windows API - Win32
A core set of Windows application programming interfaces (APIs) for desktop and server applications. Previously known as Win32 API.
2,512 questions
C++
C++
A high-level, general-purpose programming language, created as an extension of the C programming language, that has object-oriented, generic, and functional features in addition to facilities for low-level memory manipulation.
3,629 questions
Windows 10 Security
Windows 10 Security
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Security: The precautions taken to guard against crime, attack, sabotage, espionage, or another threat.
2,837 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 44,101 Reputation points
    2022-11-23T16:14:21.593+00:00

    Hi. Thank you for your question and reaching out.

    If any fingerprints remain in the Sign in option, check and remove them.

    Uninstall the device by going to Device Manager. To uninstall a device from this system, select the sub-option.

    Restart the computer

    Return to the sign-in choices and enroll the finger once more. If it doesn't work, reboot and try the full process again.

    Although I believe that this driver is partially defective, I am unable to use another one at the moment. By including my hardware id in the.inf file, I attempted to trick a newer driver into accepting this device, but it was unsuccessful.

    ------------------------------------------------------------------------------------------------------------------------------------

    If the reply was helpful, please don’t forget to upvote or accept as answer, thank you.

    0 comments No comments