Critical Error for SharePoint_Config Database

Safa 1 Reputation point

I searched all forums for three days but can't find the answer.
These topics won't work : Answer 1 Answer 2 Answer 3
The server returns this critical error:
SQL database login for 'SharePoint_Config' on instance 'ServerSql' failed. Additional error information from SQL Server is included below.
Login failed for user 'DOMAIN\SharepointServerName$'.

I set every service to use Domain\Administrator Account in windows and set this user ( Domain\Administrator) as dbowner in sql server but that don't work and I get error every 90 Seconds.

Any help will be appreciated

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,357 questions
SharePoint Development
SharePoint Development
SharePoint: A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.Development: The process of researching, productizing, and refining new or existing technologies.
1,975 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Emily Du-MSFT 29,366 Reputation points Microsoft Vendor


    I do not see that error in my side. Here is a tip you could try:

    Please go to Services -> SharePoint Timer Service -> Properties -> Log on tab -> Change the account used as farm account when in PS Configure. Then restart the SharePoint Timer Service and
    SharePoint server.


    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. Safa 1 Reputation point

    Thanks Emily, But as I said I did that before. Everything looks good but error is active every 90 Seconds.


    0 comments No comments