RDP not respecting client's desktop scale factor

Seth Weber 41 Reputation points

We upgraded our laptops and their resolution went from the old laptops' 1366 x 768 to 1920 x 1080 and this is causing our one Remote Desktop server to scale everything small so it's hard to see. I tried adding the "desktopscalefactor:i:" value in the RDP file, but RDP completely ignores this.

And I can't change the scale settings inside the remote session because it won't let you:

Client Computer Display Settings:

RDP Server Session:

I've attached the RDP file I'm using (omitting sensitive data, of course)

It's important I make the scale larger for our employees to see the text and windows easily. :)

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,567 questions
Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,381 questions
0 comments No comments
{count} votes

Accepted answer
  1. TP 83,221 Reputation points


    What version of windows is running on your server? It appears to be Windows Server 2008 R2. If that is the case the session dpi will not automatically match the client PC's dpi.

    For Server 2008 R2 there was a hotfix that would allow you to change the dpi setting within the session, log off, then log back on for the new setting to take effect. Unsure if you can still get the hotfix or not. To obtain the hotfix you would need to call Microsoft customer support and request the hotfix--make it clear you are only requesting the hotfix, not asking for any support. Requesting the hotfix is free.

    You cannot change the DPI setting through a Remote Desktop session on a computer that is running Windows 7 or Windows Server 2008 R2



0 additional answers

Sort by: Most helpful