Azure Functions in VS 2019 - missing reference assemblies

Scott Klein 26 Reputation points
2022-11-25T04:21:30.303+00:00

I am trying to build and deploy an Azure Function with VS 2019. I have installed, as far as I know, all the appropriate pre-reqs, but I continue to get the following error:

MSB3644 The reference assemblies for .NETFramework,Version=v4.8 were not found.
To resolve this, install the Developer Pack (SDK/Targeting Pack) for this framework version or retarget your application.
You can download .NET Framework Developer Packs at https://aka.ms/msbuild/developerpacks

Per this, I have installed appropriate developer packs, but still get the same error. What am I doing wrong?

Thank you in advance,

Scott

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
2,618 questions
No comments
{count} votes

Accepted answer
  1. MayankBargali-MSFT 49,961 Reputation points
    2022-11-25T11:34:13.793+00:00

    @Scott Klein Thanks for reaching out. Thanks for confirmation that you have installed the .NET Framework Developer Pack 4.8, but can you also try to install both runtime and developer .Net Framework 4.8. Restart your system and verify if you still observe the same behavior.


0 additional answers

Sort by: Most helpful