IoT Central Role permissions not working

Anon 1 Reputation point

Currently I am experiencing an issue with the permissions given to a user in IoT Central. I have users that are using a custom Role that provides a high level of access to the IoT App, including Device Groups, Dashboard creation etc. However late last week this stopped working and the user(s) have not been able to access functionality they previously had access too. I have tried changing the role to a standard IoT Central role, applying different roles with similar permission sets etc. However nothing has worked, they cannot update the widgets on a Dashboard (no data appears), they can't save a dashboard (501 error), they can't access Device Groups and other sections of IoT Central even though it appears on the side.

Has anybody else experienced this issue? How did you remediate it?

Thanks for the assistance

Azure IoT Central
Azure IoT Central
An Azure hosted internet of things (IoT) application platform.
265 questions
{count} votes

1 answer

Sort by: Most helpful
  1. SatishBoddu-MSFT 14,421 Reputation points

    Hello @Anon ,

    Just checking on this to update the thread!
    Adding details to this support case, so that other community members find this helpful with similar issue.
    Issue description

    Customer created a custom role with full-control permission of Device Groups and Dashboard and assigned it to users. However, the users cannot access the Device Groups and modifying the Dashboard with custom role.
    The users cannot modify the Dashboard with App Builder role, either.


    The product team confirmed that you were affected by two issues:

    1. A bug/regression rolled out as part of recent update. The bug was impacting the ability of non-admin users to access organizations and dashboards. The bug was fixed via hotfix.
    2. We have a non-blocking bug where in some scenarios we temporarily incorrectly cache information about the user. This leads to denying the user access to resources they are authorized for. This issue currently resolves on its own in 15-20min and the user regains access. We have filed a bug for this issue and intend to address it early 2023.


    Please send an email to us by commenting in the below section and we will work with you in offline to make sure your issue is resolved if you too have the same issue!

    Also please verify the role and permissions assigned to the user. Make sure that the role and permissions assigned to the user are correct and match the expected level of access. Check the logs. Look in the logs for any error messages that may indicate the cause of the issue. The logs can be found in the Azure portal, under "Diagnostics" in the IoT Central application.

    Sometimes the browser cache and cookies can cause issues with the IoT Central app, try clearing them and re-login.

    Manage users and roles in your IoT Central application

    Please comment in the below section, so that we can help you further on this.
    Thanks for using this forum!