SSRS fails sending O365 email [Authentication failed because the remote party has closed the transport stream]

Curt Boone 1 Reputation point
2022-11-30T14:46:06.567+00:00

Our report server stopped emailing reports due to authentication errors with the Office365 email account we are using. I'm able to send StartTLS email from powershell with the O365 account. And I am able to use a non-MS account to send mail in the report server configuration manager. All depreciated protocols have been disabled. The report server config file seems to be correct:

<SendUsing>2</SendUsing>
<SMTPAuthenticate>1</SMTPAuthenticate>

It seems to just be a problem with SSRS. The email account we are using has mfa disabled and I've reset and re-entered the password.

SQL Server Reporting Services
SQL Server Reporting Services
A SQL Server technology that supports the creation, management, and delivery of both traditional, paper-oriented reports and interactive, web-based reports.
2,874 questions
Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
7,498 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Muhammad Ahsan Khan 245 Reputation points
    2023-03-27T10:54:03.5866667+00:00

    It sounds like there might be an issue with the SSL/TLS certificate or protocol that SSRS is using to communicate with Office365's SMTP server. One possible solution is to try updating the SSL/TLS protocol used by SSRS to match the version used by Office365. Here are the steps to do this:

    1. Open the Report Server Configuration Manager and navigate to the Email Settings tab.
    2. In the SMTP Server field, enter the SMTP server address provided by Office365.
    3. Set the SMTP Server Port to 587.
    4. Set the Authentication Mode to Basic Authentication.
    5. In the User Name and Password fields, enter the Office365 email address and password.
    6. Click the Advanced button.
    7. In the Advanced SMTP Settings dialog box, set the SSL Protocol option to TLS.
    8. Click OK to close the dialog box.
    9. Click Apply to save the changes.
    10. Test the email settings to see if the issue has been resolved.

    If this does not resolve the issue, you may need to contact Microsoft support for further assistance with troubleshooting the SSL/TLS communication between SSRS and Office365's SMTP server.

    0 comments No comments

  2. sccheng888 0 Reputation points
    2024-01-28T18:48:33.46+00:00

    Hi, would you be able to provide the version of SSRS that you are referring to. it seems like this is the solution. I am currently running 15.xx and do not see the advanced button mentioned. i guess i will once i upgrade?

    0 comments No comments