Unable to connect remote VM (VM2) via RDP from the source VM (VM1) using private IP

Ramesh Naga 1 Reputation point
2020-09-29T16:05:56.613+00:00

Source VM : jumpvm
Public IP
RDP'd from workstation.

From source VM - connecting to wizlabvm (target VM) via RDP using private IP address.

Both are using same virtual network.

Following error message is showing 'An internal error occured'.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
6,795 questions
{count} votes

1 answer

Sort by: Most helpful
  1. ChristopherW-MSFT 1,601 Reputation points
    2020-09-29T17:57:49.713+00:00

    Hi @Ramesh Naga

    Do you get ''An internal error occurred" through the public RDP as well? If so, then you'll want to secure your Network Security Group attached to the Virtual Machine to prevent excess requests to TCP/3389, which can prevent the RDP Service from accepting new requests. Make sure 3389 does have a Source IP.

    If the Virtual Machine is completely private, then this can happen when:

    1. A new TLS protocol was introduced on the VM and the compatibility with other TLSs versions was not properly set.
    2. Some of the protocols TLS 1.0, 1.1 or 1.2 (server) were disabled on the VM. In particular if TLS 1.0 is disabled, this is the protocol that RDP uses
    3. A certificate was push to the tcp listener to secure RDP connections with the wrong hash
    4. The certificate is corrupted or expired

    A quick solution to most of these would be to reset the RDP Listener Settings, and the RDP Certificate. In ARM, this can be done through the Virtual Machine's Overview > Run Command, while the VM is running: RDPSettings & ResetRDPCert

    For further detailed information regarding this error, please review the 'Internal Error' Doc here: https://learn.microsoft.com/en-us/azure/virtual-machines/troubleshooting/troubleshoot-rdp-internal-error

    0 comments No comments