Older versions of Kubernetes in AKS

asked 2022-12-29T16:54:25.557+00:00
Razvan Sodoleanu 1 Reputation point

Hi everyone,

Is there any way to get Kubernetes 1.19 in AKS? Maybe in dev test labs?
I know it's no longer supported, but we have a customer running an old version of our product, and I would need to set up a test environment.

Thank you,
Razvan

Azure Kubernetes Service (AKS)
Azure Kubernetes Service (AKS)
An Azure service that provides serverless Kubernetes, an integrated continuous integration and continuous delivery experience, and enterprise-grade security and governance.
1,103 questions
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2022-12-29T17:34:24.183+00:00
    Andrew Schull 86 Reputation points Microsoft Employee

    Welcome to the Microsoft Q&A Platform.

    Thank you for reaching out & I hope you are doing well.

    From your question it looks like you are seeing if an exception can be put in to deploy a cluster in an unsupported version for testing (1.19).

    Unfortunately, at this time we do not support deploying unsupported versions of Kubernetes in AKS. The below document covers our support policy.

    Supported Kubernetes Versions

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well. Feel free to reply with any other questions or concerns. Hope this helps!

    No comments