Graph api request returns wrong data for specific mobile app in comparison to request for all mobile apps [beta]

asked 2023-01-02T14:20:50.883+00:00
Julian 21 Reputation points

I have noticed, that https://graph.microsoft.com/beta/deviceAppManagement/mobileApps returns some apps as ""isAssigned": true," if they are assigned to a group in intune, but when requesting a specific app with its id which was previously true, is now always false.
I assume this is an issue with the graph api as the result for that app should still be true

Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
2,063 questions
No comments
{count} votes

Accepted answer
  1. answered 2023-01-03T05:23:56.977+00:00
    Lu Dai-MSFT 20,896 Reputation points Microsoft Employee

    @Julian Thanks for posting in our Q&A.

    It seems a known issue. I have tested in my lab. It shows same as yours. Please understand that graph issue is more related to develop scope, Q&A has limited resources. So, it is suggested to create a premier support ticket to get more help. Here is the support link:
    https://learn.microsoft.com/en-us/mem/get-support#premier-and-unified-support-options

    Thanks for your understanding.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

0 additional answers

Sort by: Most helpful