Cannot find source control token with name github

Shivang Shrivastav 1 Reputation point


I have tried all the ways to debug the erro but still keep getting error.

I am attaching 3 screenshots to explain my error.

It is not able to deploy my web app.



Azure App Services
Azure App Services
A feature of Azure App Service used to create and deploy scalable, mission-critical web apps.
4,555 questions
{count} votes

2 answers

Sort by: Oldest
  1. Ryan Hill 16,451 Reputation points Microsoft Employee

    I think either there's an issue with token used by Azure App Service Creates or the source control property of your app service i.e., the Deployment Center blade, became corrupt. You can view these settings using and navigating to your app service resource or az webapp show --name <app name> and inspect the sourceControls property.

    I suggest unlinking the existing deployment connection and reconnecting the GitHub repo. If it still continues to fail, revoke and remove the OAuth app so that when you reinitiate the connection from the Azure portal, you'll be re-prompted to authorize the app and it should get a new token.

  2. Paulo Vicente Valente 0 Reputation points

    I solved the problem in an expected way. I downgraded the node version from 18 to 16. I was using the incorrect node version, but, the error presented was: "Cannot find source control token with name Github". My understanding is that the issue was mapped to the wrong error.