Azure ML No Code Responsible AI Failed because package versions have conflicting dependencies

Connie Rodriguez 0 Reputation points
2023-01-11T19:48:18.84+00:00

Hello all,

I have a registered Machine Learning model (Type is MLFLOW) and I'm trying to generate a Responsible AI dashboard through the UI. After submitting the job, it fails when trying to execute the RAI Insights Dashboard Constructor component. The error says to check the log file and the log file is very clear about what the problem is: package versions have conflict dependencies.

AzureError

I've been searching the web for solutions but I do not know where the requirements.txt file comes from when trying to create the dashboard using the no-code UI. It seems to be like I should be able to resolve this issue if I'm able to find and edit the file to change the azure-identity==1.11.0 to 1.7.0.
Thanks ahead of time :)

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
1,640 questions
{count} votes