AzureMonitorWindowsAgent version 1.11.0.0 status creating, not changing

Mikael Braad Nielsen 21 Reputation points
2023-01-12T17:38:11.5033333+00:00

After installering/updating to AzureMonitorWindowsAgent version 1.11.0.0 on a windows 2012 r2, i created a data collection rule and associated the server to the rule.

In the arc menu for the server and below extentions, i can now see AzureMonitorWindowsAgent have the status creating.

The problem is, even after an period, the status don't change and i don't get any log from the server anymore.

I have tried removing agent from the server and install it again.

I have tried in powershell to remove the extension again with the command Remove-AzConnectedMachineExtension

It gives following output:

Remove-AzConnectedMachineExtension : An extension of type AzureMonitorWindowsAgent is still processing. Only one instance of an extension may be in progress at a time for the same resource.

At line:1 char:1

I have been through the log files in

C:\ProgramData\AzureConnectedMachineAgent\Log

for any errors og bad connections.

Do anyone have some good hints ?

Thank you in advance

Azure Arc
Azure Arc
A Microsoft cloud service that enables deployment of Azure services across hybrid and multicloud environments.
139 questions
Azure Monitor
Azure Monitor
An Azure service that is used to collect, analyze, and act on telemetry data from Azure and on-premises environments.
1,823 questions
{count} votes

1 answer

Sort by: Most helpful
  1. AnuragSingh-MSFT 10,056 Reputation points Microsoft Employee
    2023-01-16T10:09:48.9933333+00:00

    Mikael Braad Nielsen I could not understand the following point in the question -

    "After installering/updating to AzureMonitorWindowsAgent version 1.11.0.0 on a Windows 2012 r2, i created a data collection rule and associated the server to the rule."

    There are 2 ways to install Azure Monitor Agent (AMA) on a VM

    Using the agent extension - This method adds the extension after DCR has been created and associated with the VM. (There are other ways to enable it as well, which is available in the link here). As you have mentioned that you can see the extension option in VM to always show extension in "creating" state, I assume that you have followed this step for enabling the AMA. The following steps should help troubleshoot/diagnose this issue further

    • On the Arc connected machine, run azcmagent show. Ensure that the "Agent Status" is available as connected, and all the "Dependent Service Status" are in running state (if not, the arc agent on the local machine is not able to connect to the Azure platform which is causing the status of extension to be stuck in Creating state) User's image
    • You could run azcmagent log to collect all the associated logs for the arc enabled machine and see if there are any errors in one of them. Also, check the extension report available in %ProgramData%\GuestConfig\extension_reports for any errors related to extension installation itself.
    • The general troubleshooting steps available in the following article should also help you troubleshoot this issue better - General troubleshooting for Ar enabled server's extension installation
    • In case the steps above do not help, I would suggest opening a support ticket to help investigate this issue in detail. You can see this link for details.

    Using Windows Client Installer - Based on the nature of this issue, I dont think this method was used.

    Please let me know if you have any questions. Please 'Accept as answer' and ‘Upvote’ if it helped so that it can help others in the community looking for help on similar topics.