Please assist Pass through not working on host pool vm

Komail Chaudhry 0 Reputation points
2023-01-23T10:02:04.2766667+00:00

I have 3 VMS, 1 DC, 1 File Server and 1 Host pool with one VM. I have AD Connect and All 3 Servers are joined to the domain. I am able to login to the DC and FileServer with full name@email.com no issue but the host pool vdi when I login through Remote Desktop app and sign into the account it works fine up until I click the RDP Icon and it has a Logon failure and I have to change the username to Domain\username instead of the email. I have reached out to support multiple times and no one has been able to assist. I have redeployed the VM multiple times and tried most soultions.

-The Domain is now hybrid and I can RDP from DC to VDI0 with full Email UPN but when using Remote desktop app, I am still getting Logon failure. No further error code.

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,314 questions
Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
18,620 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Komail Chaudhry 0 Reputation points
    2023-01-25T03:28:12.66+00:00

    The UPN in the AD Setup says its synced to the proper domain.ca but still not working, I was able to attach my device to Azure AD and now the full email works, but this is not ideal as some users won't be using azure joined computers

    0 comments No comments