Netlogon Replication Problem

JRL 20 Reputation points
2023-03-31T13:53:14.9633333+00:00

I have an unusual replication issue and I do not want to force a non-authoritative restore when replication I feel is working for the most part just not the netlogon share but only when it comes to a particular DC. The policies folder on the sysvol replicates just fine and the netlogon share does as well but only if the action is initiated on one of the two DCs when it comes to creating a new file. When it comes to deleting that same file I can initiate from either DC and it deletes from both DCs fine.

Let me explain:

I have 2 DCs, on DC1 if I create a new file in the netlogon(scripts) folder in sysvol I immediately see it replicated to DC2. On DC2 if I create a new file, it never replicates to DC1. However, if I delete the file that was created on DC1 from DC2 netlogon directory, then I immediately see it deleted from both DCs. So it seems it is only the write attempt from DC2 to DC1 that is having the issue. Permissions have not been modified from default of course but I did verify via ADSI and all are correct/identical on all partitions compared to that on another one of our domains that is working as expected. There are no replication errors when I run any of the dcdiag checks and repadmin is also error free so I am trying to see if anyone can provide insight as to why this may be happening before I dive too deep with verbose corrective actions that might not be needed. Thank you.

Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
6,000 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 426.2K Reputation points MVP
    2023-03-31T17:47:39.1766667+00:00

    One option may be to move roles off, demote, reboot, promo the problematic one.

    --please don't forget to upvote and Accept as answer if the reply is helpful--


1 additional answer

Sort by: Most helpful
  1. Thameur-BOURBITA 32,606 Reputation points
    2023-03-31T20:30:10.49+00:00

    Hi,

    Repadmin command shows errors on AD replication and not sysvol replication .

    Check if you get error related to sysvol replication on event viewer of each DC and when you launch dcdiag command.

    Check if the network flow is ok between the two DC.

    Don't hesitate to share with us the message error.

    Please don't forget to mark helpful answer as accepted