Wingmt does not exist/Constant PC crashes

Jozef Andrzej Niemtus 0 Reputation points
2023-04-14T22:39:19.9233333+00:00

Before I start, I am by no means a technical wizard. I work as a 2nd line analyst so know the odd thing but I am really stuck with this one. My PC has started having some really bad performance spikes, mainly in the CPU. I used ChatGPT as all my vague google searches came up with nothing useful, and I found that I had a lot of errors in my event viewer under \applications and services\Microsoft\Windows\WMI-Activity\Operations. All of the errors seemed to be slightly different but whenever I copied them into ChatGPT, it would come up, mostly, with the same answer about my wingmt service. After typing the comand, wingmt /resetrepository, it came back with 'wingmt' is not recognized as an internal or external command, operable program or batch file. It also asked me to go onto registory editor and navigate to \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WMI\Autorecover, but the Autorecover folder was not there, However the WMI folder was and it contained Autologger, GlobalLoggs and Security. Another problem I have noticed is that my local device security on my windows security has stopped working and my TPM seems to have disapeared. I have tried to reinstall windows, but this has not worked. I am truly stuck with this and would massively appreciate any help.

Windows 11
Windows 11
A Microsoft operating system designed for productivity, creativity, and ease of use.
8,362 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 43,986 Reputation points
    2023-04-17T13:43:15.1233333+00:00

    Hello there, For the error message regarding wingmt Check the status of the Windows Management Instrumentation Service. The issue occurs if the WMI (Windows Management Instrumentation) service is not running or stopped. You can check the status of the WMI Service in the Windows 11/10 Services app. If the service is stopped, start it. If the WMI Service is already running or if after starting the WMI Service, the error still persists, the problem is occurring because the WMIC program is not available in the system path. To fix the issue, you have to add the path where the WMIC executable is located to the System Variable. Hope this resolves your Query !! --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments