How can I get Dolby Atmos working in Windows 10 with HDMI and RTX4090

Guy WHo wants ATmoS 0 Reputation points

Hi there,

I'm trying to get Dolby Atmos working in windows 10. I've used it before with my RT3080 and this time its just not showing up as an option under Spatial Sound. However, exclusive mode games that have Atmos it works perfectly and it also works perfectly in the Dolby Access App if i have dolby atmos for headphones enabled.

I have an LG B2 tv with a Sonos Bean sound bard connected via eArc. I know they both support it. My HDMI is giving me 120hz 4k flawlessly.

I just can't set it in Spacial Audio for my TV HDMI audio device. Its not an option.

I'd love any help anyone can offer.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
9,473 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Vahid Ghafarpour 8,390 Reputation points

    If Dolby Atmos is not showing up as an option under Spatial Sound in Windows 10, there are a few things you can try:

    Check that your audio device and drivers support Dolby Atmos. You mentioned that your LG B2 TV and Sonos Beam soundbar support Dolby Atmos, but it's also important to make sure that your audio drivers are up-to-date and support Dolby Atmos. You can check for driver updates using the Device Manager in Windows.

    Make sure that Spatial Sound is enabled in Windows. To do this, go to Settings > System > Sound > Sound Control Panel > Playback tab, select your audio device, and click Properties. Under the Spatial sound tab, select "Windows Sonic for Headphones" or "Dolby Atmos for Headphones" if available.

    Try disabling other audio enhancements. If you have other audio enhancements enabled, they may interfere with Dolby Atmos. To disable other audio enhancements, go to the Enhancements tab in the Properties window for your audio device and uncheck all enhancements.

    Check that Dolby Atmos is enabled for your audio device. To do this, open the Dolby Access app and make sure that Dolby Atmos for Headphones is enabled for your audio device.

    Try resetting the Windows audio settings. To do this, go to Settings > System > Sound > Reset, and click the Reset button under the Reset your audio settings section.

    Try reinstalling the audio drivers. If none of the above steps work, try uninstalling and reinstalling the audio drivers for your audio device.

    0 comments No comments