Unable to assign owners to private channels with Graph API

Félix Pelletier 0 Reputation points


I've previously created an issue on GitHub because I was unable to assign owners to a private channel. I encountered the same error response when I executed the request directly in the Graph Explorer without going through the SDK (tried both v1.0 and beta routes):

  • URL: https://graph.microsoft.com/{version}/teams/{team-id}/channels/{channel-id}/members/microsoft.graph.add
  • Verb: POST
  • Request's payload: same as this example
  • Response
    • Code: UnknownError
    • Message: 404 page not found

The user who executes the request has the appropriate delegated permission required to manage channel membership, as dictated here.

Note that I mitigated this problem by instead defining the channel membership when I created the channel rather than post creation, but I thought it would be good to raise the issue so that it can be resolved for good.

Microsoft Graph
Microsoft Graph
A Microsoft programmability model that exposes REST APIs and client libraries to access data on Microsoft 365 services.
9,144 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Antonio 260 Reputation points Microsoft Vendor

    Hi Félix Pelletier,

    Thanks for posting in the Q&A forum. We need a bit more details on the error code and message that you are seeing.

    We recommend to open a case with Azure supportso that this can be addressed directly to our support staff.

    0 comments No comments