Issue In Unattend File To Create Windows 2019 Template For Provisioning

Mohammed Elsioufy 0 Reputation points

Hello Microsoft support

I have an issue creating a windows server 2019 VM on hyper-V for provisioning.

I have used the unattend file attached to create a windows server 2019 template and it gives me below error as screenshot below when I have created a VM through the template.

User's image

Are there any changes I could make in the specialize settings in the unattend file to solve the issue without changing setup.exe registry key to 3 from the backend ?

Thanks in advance

Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management updated to data storage.
3,160 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. Limitless Technology 43,231 Reputation points


    The issue is described here, and it applies both to Azure and Hyper-V.

    Ideally you should run the /shutdown at the end of your sysprep in order to "clean" shutdown: sysprep /oobe /generalize /unattend:<your file's name> /shutdown but depending on the unattended file it may fail.

    --If the reply is helpful, please Upvote and Accept as answer--

    0 comments No comments

  2. Mohammed Elsioufy 0 Reputation points


    I have tried to apply the workaround in the link but the template didn't work, I would like to know also if you mean that during Sysprep preparation pnly I shouldn't use flag unattend.xml or what ? I have tried to apply only flags sysprep /oobe /generalize /shutdown without attend.xml but placed it in the Sysprep files that the template I have prepared should use to create the VM on the Hyper-V from the control Panel but gives me below error as screenshot below.

    User's image

    Do you have any modifications that should be applied to the unattend.xml file as I need it in provisioning ?

    Thanks in advance.

    0 comments No comments

  3. Mohammed Elsioufy 0 Reputation points

    Hello Microsoft Support

    I have prepared an unattend.xml file and it worked with the template I have made and created a machine through it without errors, but still have an issue bypassing EULA , however I have added the below command to accept it




    Do you have suggestions to bypass it ?

    You can find the unattend file I have prepared attached to my reply.

    0 comments No comments

  4. Mohammed Elsioufy 0 Reputation points
    0 comments No comments