Distribution Manager failed to find or create the defined share

M Tran 481 Reputation points
2023-05-05T21:37:22.93+00:00

Hi,

I am aware that this issue has been posted and I viewed all the related posts that popped up, but no results. One of my remote DPs (only one having issue) all of a sudden threw up these 2 errors below. It has been 2 weeks and I am at wit's end.

User's image

User's image

From the distmgr.log, these are what I found:

CWmi::Connect() failed to connect to \\CLE-SCCM-DSTPT1\root\CIMv2. Error = 0x800706BA

ERROR DPConnection::ConnectWMI() - Failed to connect to CLE-SCCM-DSTPT1. error = 0x800706ba

Failed to find a valid drive on the distribution point ["Display=\\CLE-SCCM-DSTPT1.\"]MSWNET:["SMS_SITE=PLA"]\\CLE-SCCM-DSTPT1.\

My DP still has the E drive with 106 GB free.

I turned off firewall but that did not help.

I can remotely connect and test wmi no issue.

A post suggested to remove and reinstall the DP, but before I go this route, I am hoping someone can shed some lights.

Thank you!

Microsoft Configuration Manager
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. CherryZhang-MSFT 6,481 Reputation points
    2023-05-08T07:49:57.33+00:00

    Hi @MTran

    My DP still has the E drive with 106 GB free.

    1, You mean that your content library and package share are stored on E drive, right? (Please let me know if I misunderstand something.)

    1

    2, Please help check whether you have the latest security update KB5004442 installed on DP server? Someone fixed this error by installing it on all servers. The related link for your reference:

    Issue with DP CWmi::Connect() failed to connect to Error = 0x800706BA - Microsoft Q&A

    The error code 0x800706ba means RPC server is unavailable, the article about KB5004442 recommends us to verify if client or server applications in our environment that use DCOM or RPC work as expected with the hardening changes enabled. The related link:

    KB5004442—Manage changes for Windows DCOM Server Security Feature Bypass (CVE-2021-26414) - Microsoft Support

    Looking forward to your reply.

    Best regards,
    Cherry


  2. M Tran 481 Reputation points
    2023-06-02T19:22:38.97+00:00

    Hi @CherryZhang-MSFT

    I just wanted to update you on this. We have figured out the issue. I would like to post it here so to help anyone running into the same problem to check it.

    The issue was a combination of our outdated barracuda and the time configuration on the VMware ESXi host. Correcting the time on the vmware host fixed the issue. We are removing barracuda from our environment.

    so, if anyone running into the same issue, check the network time.

    thank you!

    0 comments No comments