IIS8 URL Rewriting Not Working for RSS Feed - Troubleshooting Query

alivenjess 1 Reputation point

I am facing an issue with URL rewriting on IIS8. Specifically, I'm having trouble redirecting the URL "https://www.domain.com/all_job_list.php?category=1" to "https://www.domain.com/all-job-list/ Accounting-bookkeeping. Despite implementing the necessary rules, the site continues to load the same source under the original URL.

Here is the rule I have added:

php Copy code <rule name="generated-0" stopProcessing="true"> <match url=".*" /> <conditions logicalGrouping="MatchAny"> <add input="{URL}" pattern="https://www.domain.com/all_job_list.php?category=1$" /> </conditions> <action type="Redirect" appendQueryString="false" url="https://www.domain.com/all-job-list/Accounting-bookkeeping/" redirectType="Permanent" /> </rule> I even attempted to use a basic rule, but it did not work either. I have installed the URL Rewrite module from "http://www.iis.net/downloads/microsoft/url-rewrite" and even tried uninstalling and reinstalling it, but the issue persists.

Could someone please help me identify what might be causing this problem? Are there any additional steps or configurations required for IIS8 (Windows Server 2012) servers?

Thanks in advance for your assistance.

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,574 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 44,096 Reputation points

    Hello there,

    Reinstall rewrite module. If you don't see this module in IIS and installed application list but rewrite installer says thar is is already installed go to registry (HKLM/SOFTWARE/MICROSOFT/WINDOWS/CURRENTVERSION/Uninstall) and serach 'rewrite'. Find uninstall string and run it. It will remove rewrite module and you can install from scratch.

    Install Application Request Routing module for IIS.

    IMPORTANT! If you already have web.config with rules remove them. Create/add rules via IIS menu. This way IIS will activate ARP module that is important.

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer--

    0 comments No comments