VM machine running but not able to access website or connect via SSH

Matthew Tomsho 20 Reputation points

We have not made any configuration changes to our Azure VM. The VM had not been in use much. When try to access the web page, after about 5 minutes or so it returns an error. Cannot SSH into the VM. If restart the VM, sometimes can SSH in, but VERY slow. If restart VM sometimes website comes up, but immediately fails when trying to access the local MySQL Database (connection refused), eventually (several hours later) nothing is available again.

Admin console says agent status is not ready. When click link to troubleshoot get the following message from diagnostics:

We ran diagnostics on your resource and were unable to identify a specific issue

Looking for guidance on what to check. I'd hate to have to rebuild the VM from scratch.

Azure Virtual Machines
Azure Virtual Machines
An Azure service that is used to provision Windows and Linux virtual machines.
7,515 questions
0 comments No comments
{count} votes

Accepted answer
  1. Jackson Martins 10,136 Reputation points MVP

    Hi @Matthew Tomsho

    The symptoms mentioned suggest two potential issues:

    1. High CPU usage, which could potentially lead to a slowdown when accessing SSH, and, subsequently a timeout. Two possible solutions for this issue could be:

    a. Temporarily scaling up the machine size, then connecting and terminating the application with high CPU usage.

    b. Connecting via console to halt applications that might be causing excessive CPU usage.

    Please review the monitoring metrics in the Azure portal to determine if this is indeed the case.

    1. The presence of an internal firewall that's blocking connections. You might be able to connect via SSH before the firewall settings take effect. In this case, there are two potential solutions:

    a. Connect via console and disable any firewalls, such as SELinux, ipbtables, or others.

    b. Launch a new VM, attach the disk from the problematic VM, then access the startup files and disable the firewall.

    Get in touch if you need more help with this issue.

    --please don't forget to "[Accept the answer]" if the reply is helpful--

0 additional answers

Sort by: Most helpful