My ContainerApp keeps intermittently resetting itself, Can't found any logs about the problem.

Tong Luo 0 Reputation points
2023-05-23T07:31:00.9366667+00:00

Here are my reproduction steps (my subscription is 'Pay as you go'), and you can also try them out as they are very simple:

  1. Create a new ContainerApp, give it a name and fill in basic information;
  2. On the "Container" option, uncheck the quick start image and use Docker Hub. Enter "xhofe/alist" for the image, and enter the following three environment variables: "PUID:0 - PGID:0 - UMASK:022";
  3. On the "Ingress" option, select to accept traffic from any location, choose HTTP, and enter 5244 for the target port;
  4. Click Next until you reach "Review and Create", then click Create and wait for deployment to complete.

The initial administrator password can be obtained by entering "./alist admin" in the "Console" section of the Container management page when logging in for the first time. By now, you should have created this container and can access the web management page by clicking on "Application URL" in the container overview.

Here are the issues I encountered:

No matter what modifications you make on the web page afterwards, when you close the page and reopen it after about 5 minutes, you will find that all previous configurations have been reset to their initial state and need to be reset again (This is manifested as the Admin password that was just obtained is no longer able to log in to the page, and needs to be obtained again from Console). I have tried to add persistent storage without any improvement, and I have also tried to switch to another Web container image for other projects, but the situation remains the same. I suspect that this ContainerApp only allows for stateless container deployment, or is it a pricing issue?

Azure Container Apps
Azure Container Apps
An Azure service that provides a general-purpose, serverless container platform.
344 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. AirGordon 7,030 Reputation points
    2023-05-23T12:20:22.47+00:00

    You need to ensure that the Container Apps Environment is configured with Log Analytics logging.
    This will capture the ContainerLog output you need to troubleshoot the problem.
    https://learn.microsoft.com/en-us/azure/container-apps/log-options