Edge places a modal Popup asking me to log into an unknown Outlook account. When I click away it returns instantly

anke hillier 20 Reputation points
2023-05-30T07:48:31.22+00:00

Edge places a modal Popup asking me to log into an unknown Outlook account. When I click away it returns instantly.

At the moment I can't use Edge because of this. I don't even have time to switch tabs

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,234 questions
Outlook
Outlook
A family of Microsoft email and calendar products.
3,406 questions
{count} votes

Accepted answer
  1. ShiJieLi-MSFT 8,731 Reputation points Microsoft Vendor
    2023-05-31T03:10:02.76+00:00

    Hi @anke hillier ,

    You can try the following troubleshooting steps:

    1. Clear cookies of Microsoft Edge. This account seems to be stored in cookies, so you can see this account every time. To clear cookies, you can Edge settings --> Privacy, search, and services --> Clear browsing data.
    2. Check whether this account is logged in at Email & accounts in System settings. If you can find it, just remove it.
    3. Check whether this account is logged in at your Edge profile. If you can find it, just remove it.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,

    Shijie Li

    1 person found this answer helpful.
    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. anke hillier 20 Reputation points
    2023-05-30T09:58:43.03+00:00

    Sure. Here's the screenshot.

    The account is completely unknown to me. If I click the Wachtwoord vergeten/ Forgotten Password button, the last two digits of the telephone number it suggests are also unknown to me.

    User's image

    Thanks

    0 comments No comments