RDSFarm: 2 users rdweb login ok, but remoteapp says credentials are wrong

Jurgen Verhelst 326 Reputation points
2023-05-31T08:57:56.58+00:00

SETUP

RDB/RDGW/RDWA 1 remoteapp session host (All Win 2022)

ISSUE

  • A few times a month some users report that the win 10/11 remotapp work resources are listed but upon connection it states the credentials did not work and need to provide them again.
  • users can login to fqdn/rdweb website and see the remoteapps listed but same issue when opening a RemoteApp. keeps asking for credentials. remember, the creds are correct or the user would not have been able to login to RDweb site.
  • Remarkably, the rdweb/webclient (html5) does work and apps open up in the browser.
  • so it seems to point to issue to be on RDG or Broker?
  • on the RDB is see no errors in eventviewer and see in the log of TS Sessionbrokers that users are being added to the DB and pointed to the RA session host (eventid 787 and 1307).
  • Also logging in directly on session host via teamviewer using that user cred works

Any pointers?

Remote Desktop
Remote Desktop
A Microsoft app that connects remotely to computers and to virtual apps and desktops.
4,397 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Limitless Technology 44,101 Reputation points
    2023-06-02T11:22:09.41+00:00

    Hello there,

    This error is often caused by Windows policies that prevent incoming RDP connections, or simply your system's username.

    This might be an issue with the permissions of the group that you have given to the users. By default members of the Administrators group have this right.

    I would suggest you Verify RemoteApp and Desktop Connection Functionality by following the below link

    https://learn.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/dd941627(v=ws.10)

    Also have a quick recap on the Installing and Configuring RemoteApp https://learn.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/dd772730%28v%3dws.10%29

    The below thread discusses the same issue and you can try out some troubleshooting steps from this and see if that helps you to sort the Issue.

    https://social.technet.microsoft.com/Forums/ie/en-US/4560fabc-eeeb-47bc-958b-ff84b27820a8/remoteapp-keeps-saying-quotyour-credentials-did-not-workquot?forum=winserverTS

    Hope this resolves your Query !!

    --If the reply is helpful, please Upvote and Accept it as an answer–

    0 comments No comments