Exchange online plan 1 504 5.7.4 Unrecognized authentication type

FTINC 116 Reputation points

I recently changed my email hosting to Microsoft Exchange online (plan 1). I have a windows desktop application and a scanner that I need to send emails from using SMTP. When I setup my account on the scanner device and software, I get the error "504 5.7.4 Unrecognized authentication type". How do I fix this error?

I have followed the directions:
How to set up a multifunction device or application to send email using Microsoft 365 or Office 365, Option 1

Outlook on the web works, logon with username and password, send and receive emails.
Multifactor Authentication is disabled.

I have tried using the following host information, all returning the same error:
<mydomain>, port 25, port 25, port 587

My account is licensed: Exchange Online (Plan 1)

In Microsoft 365 admin center, active users, my user, manage email apps: (all are checked)
Outlook on the web - checked
Outlook desktop (MAPI) - checked
Exchange web services - checked
Mobile (Exchange ActiveSync) - checked
IMAP - checked
Pop - checked
Authenticated SMTP - checked

In Exchange properies for account:
Outlook on the web - enabled
Outlook desktop (MAPI) - enabled
Exchange web services - enabled
Mobile (Exchange ActiveSync) - enabled
IMAP - enabled
Pop - enabled

Using SMTP Diag tool, I get the following log trying to send an email:

Connecting to mail server.
220 <isthisprivate> Microsoft ESMTP MAIL Service ready at Tue, 20 Oct 2020 18:02:19 +0000
250-<isthisprivate> Hello []
250-SIZE 157286400
504 5.7.4 Unrecognized authentication type [<isthisprivate>.CANPRD01.PROD.OUTLOOK.COM]
Forcing disconnection from SMTP server.
221 2.0.0 Service closing transmission channel


Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
3,161 questions
No comments
{count} votes

Accepted answer
  1. FTINC 116 Reputation points

    Following the instructions did not work for me because I didn't recognize that Azure AD was being used. We only signed up for Exchange Online and wasn't aware Azure AD was being used as well, once I figured out that Azure AD was being used and those settings applied, it worked.

2 additional answers

Sort by: Most helpful
  1. KyleXu-MSFT 25,746 Reputation points

    Yes, you found the correct article to configure Exchange Online Relay Email for your application. However, we don't know how your application works. We recommend that you use this article to confirm with your application provider to check which option your application supports. Then, try to use the correct, the option 1 and 2 aren't supported by all application/device.

    You can also try to use the option 3 to create a dedicated SMTP relay connector to relay email from your application.

    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  2. Dan 1 Reputation point

    I really wish @FTINC had provided a better answer. I'm really stuck on this and they've perfectly described everything I've also tried to get our scanner to send with SMTP AUTH unsuccessfully. I still haven't figured out what I'm doing wrong.