How can we, in Azure Virtual Desktop, disable the exchange of files between the virtual desktop and local client, but still allow the copy-paste of plain text from clipboard?

Mourad Ouled Larbi 0 Reputation points
2023-07-20T09:13:50.6733333+00:00

How can we, in Azure Virtual Desktop, disable the exchange of files between the virtual desktop and local client, but still allow the copy-paste of plain text from clipboard?

Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,314 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Prrudram-MSFT 20,761 Reputation points
    2023-07-20T10:43:14.06+00:00

    Hello @Mourad Ouled Larbi

    To disable file exchange between the virtual desktop and local client, but still allow copy-paste of plain text from clipboard, you can configure the Remote Desktop client settings. Here are the steps to do so:

    1. Open the Remote Desktop client on your local device.
    2. Click on the Show options button to expand the settings.
    3. Click on the Local Resources tab.
    4. Under the Local devices and resources section, click on the More... button.
    5. Uncheck the box next to Drives to disable file exchange.
    6. Check the box next to Clipboard to enable copy-paste of plain text.
    7. Click OK to save the changes.
    8. Connect to your Azure Virtual Desktop session

    Please note that if your admin has disabled these settings in Azure Virtual Desktop, you may not be able to change them.
    Let me know if that helps!
    If this does answer your question, please accept it as the answer as a token of appreciation.


  2. Prateek Singh 0 Reputation points
    2023-07-21T21:18:22.3766667+00:00

    Hi,

    You can enable the copy paste text via GPO

    Follow the below steps -

    Go to - HKLM\software\policies\microsoft\windowsNT\terminalserver

    Set "Do Not Allow Device Redirection" as Enable

    Run GPUPDATE /force

    or wait for 30-45 to replicate the GPO and then check. It should work.

    0 comments No comments