Defender for API, Deadlock Recommendations want plan enabled, plan already is enabled

Stefan Schulte 0 Reputation points
2023-08-02T09:08:32.3+00:00

Hello community!
I followed the steps in https://learn.microsoft.com/en-us/azure/defender-for-cloud/defender-for-apis-deploy?WT.mc_id=Portal-Microsoft_Azure_Security

Enabling the Defender for APIs plan is done.

After that, the manual stated, that there should pop up the recommendation "Azure API Management APIs should be onboarded to Defender for APIs."

Instead of the wanted recommendation there is "Microsoft Defender for APIs should be enabled" (Which already is)

So I am now in a kind of Deadlock

Thanks a lot for any suggestions

Microsoft Defender for Cloud
Microsoft Defender for Cloud
An Azure service that provides threat protection for workloads running in Azure, on-premises, and in other clouds. Previously known as Azure Security Center and Azure Defender.
1,123 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Akshay-MSFT 15,036 Reputation points Microsoft Employee
    2023-08-03T07:03:28.2533333+00:00

    @Stefan Schulte

    Thank you for posting your query on Microsoft Q&A. From above query I could understand that you are following Protect your APIs with Defender for APIs and have enabled Defender for APIs plan but Defender for APIs is missing from the recommendations and instead you are getting Microsoft Defender for APIs should be enabled among recommendations.

    User's image

    Please do correct me by responding in the comments section if this is not the case.

    This behavior is expected as After enabling Defender for APIs, onboarded APIs take up to 50 minutes to appear in the Recommendations tab.

    You may try now, and the Defender for APIs should be available in recommendations.

    Thanks,

    Akshay Kaushik

    Please "Accept the answer" (Yes), and share your feedback if the suggestion answers you’re your query. This will help us and others in the community as well.