WSUS post installation wizard keeps pop out after in-place Windows Server upgrade

thenewmessiah 41 Reputation points
2020-10-22T15:56:41.627+00:00

Hi All,
I have recently ran an in-place upgrade from a Windows Server 2012 R2 (with WSUS role) to Windows Server 2016.
Everything works fine, but if I launch the WSUS MMC on the server itself, it show me this window:
34356-wizard.png

I have completed the wizard setting the previous WSUS content directory, and after all it shown an error with this log (see attached file).

If I connect from a remote MMC the WSUS seems to be working fine, but on the server it still show me that wizard.

In the registry, the content path is correct.

Do you have any idea on what can be happened?

Thanks in advance34348-tmpb6dctmp.txt

Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
11,749 questions
0 comments No comments
{count} votes

2 additional answers

Sort by: Most helpful
  1. Rita Hu -MSFT 9,566 Reputation points
    2020-10-23T06:59:20.507+00:00

    Hi thenewmessiah-5920,

    Thanks for your posting on Q&A.

    It seems that the issue is related to the permission. I found a related case for your reference:
    https://social.technet.microsoft.com/Forums/en-US/5d07cb92-e2ad-4a64-a92f-d7cf980fb47d/wsus-post-installation-failed-with-error-request-for-principal-permission-failed?forum=winserverwsus

    It is recommended to edit the WsusPool.config file's permission. Please refer to the below path to check the file's location:
    C:\inetpub\temp\appPools\WsusPool

    Here is a related picture of my environment for your reference:

    34488-2.png

    If there is any feedback, please let me know.

    Regards,
    Rita


    If the response is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments

  2. thenewmessiah 41 Reputation points
    2020-10-23T15:33:09.14+00:00

    Thank you all!
    My settings was almost all ok.
    I have only changed this:

    • Read setting for Network Service on the E:\ drive (the wsus content folder was already ok)
    • I have launched the WSUS console as Admin (even if my account is an administrator one)
    • I have added this to the registry "Full Control permissions to the \HKLM\Software\Microsoft\Update Services\Server\Setup"

    Now the wizard no longer appears.

    0 comments No comments