Intune Application - App installed but showing failed

Cesar Diaz 0 Reputation points

So I'm downloading BitWarden on all staff devices and they're all successfully installing on the remote machines, but the detection is continuously failing.

I've tried registry detection (didn't work) and tried "file exists" detection and it keeps coming back as failed.

I confirmed the file path is consistent across all machines on the installation. The file path is :

C:\Program Files\Bitwarden

I've set this exact file path in the detection method and looking for file "Bitwarden" but as I said, the detection keeps failing. It's not drastically impacting performance or work, but it's annoying seeing it fail in the dashboard. Another thing that it's doing, is re-initializing the installation every time the machines sync which pops up with a window saying the installation failed for them multiple times a day, when it didn't.

Intune status details :

The application was not detected after installation completed successfully (0x87D1041C).

Not sure what's going on when the installations are consistent and the file path I've set to detect is also consistent. Other posts asking this same question have not resolved it for me.


Microsoft Intune Application management
Microsoft Intune Application management
Microsoft Intune: A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.Application management: The process of creating, configuring, managing, and monitoring applications.
748 questions
Microsoft Intune
Microsoft Intune
A Microsoft cloud-based management solution that offers mobile device management, mobile application management, and PC management capabilities.
3,297 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. ZhoumingDuan-MSFT 1,090 Reputation points Microsoft Vendor

    @Cesar Diaz, Thanks for posting in Q&A. 

    I noticed that you have submitted two threads with the same issue, for your issue, to avoid confuse, I will put the troubleshoot under this thread.

    From your description, we understand that you have deployed a win32 app and it install successfully on targeted device, but the detection failed. Could you please provide us your Registry settings in Intune?

    Moreover, could you please help us confirm that if the installation package you package and upload to Intune is .MSI format? if yes, please try the MSI detection method to see if it can work.

    Please check the above information and if there’s any update, feel free to let us know.

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.