Only admin of B2C Tenant lost access to the auth app and can't login anymore

Philipp Pradzinski 0 Reputation points


so I created an Azure AD B2C tenant for testing purposes and transferred my Visual Studio Enterprise Subscription to it, so I could test services. The AD B2C had MFA enabled and I used it with the Microsoft Authenticator App. It worked fine until I deleted the "entry" in my MS Authenticator App. I wanted to "reset" the MFA currently using MS Authenticator App to another authenticator app but after deleting it in my MS Authenticator App, the login for the B2C Tenant still asked for the MFA of the Microsoft Authenticator App. Now here I am, clueless about how I could restore my access...

The main problem is, that my Visual Studio Enterprise Subscription is currently stored in this tenant, otherwise I would just delete the B2C-Tenant and create a new one..

Before "deleting" the entry in my MS Authenticator App, I tried to "reset MFA" for my user in the B2C tenant itself but the portal just gave me an error that led me to this situation.

Any ideas?

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
16,646 questions
A cloud computing platform and infrastructure for building, deploying and managing applications and services through a worldwide network of Microsoft-managed datacenters.
564 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Dillon Silzer 46,036 Reputation points

    I'd recommend calling Microsoft Business Support:

    If you are locked out of your tenant you will want to reach out and explain the situation.

    Get support for Microsoft 365 for business

    If this is helpful please accept answer.

    0 comments No comments