serviceconnectiontool error prereqs for this tool do not seem to be satisfied

David Zemdegs 1,586 Reputation points
2023-09-12T02:16:14.4533333+00:00

Hi,

We have to get CM updates using the serviceconnectiontool. I have run this dozens of times without a problem. This time we are currently on 2211 and want to download 2303. However, running the serviceconnectiontool throws up an error saying something like 'pre-reqs for this tool do not seem to be satisfied'.

the usagedata.cab file seems to have lots of good stuff in it.

Any ideas?

Thanks

David Z

Microsoft Configuration Manager
0 comments No comments
{count} votes

Accepted answer
  1. AllenLiu-MSFT 42,901 Reputation points Microsoft Vendor
    2023-09-26T06:08:29.38+00:00

    Hi, @David Zemdegs

    Thanks very much for your feedback. We're glad that the problem is solved now. Here's a short summary for the problem, we believe this will help other users to search for useful information more quickly.

    Problem/Symptom:

    When running the serviceconnectiontool, it throws up an error saying: 'pre-reqs for this tool do not seem to be satisfied'.

    Solution/Workaround:

    Downloading the component Visual C++ Redistributable Packages for Visual Studio 2013 is not enough.

    Also install VC++ 2022 fixed the issue.


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click ""Add Comment".

    1 person found this answer helpful.
    0 comments No comments

2 additional answers

Sort by: Most helpful
  1. AllenLiu-MSFT 42,901 Reputation points Microsoft Vendor
    2023-09-12T07:29:46.2366667+00:00

    Hi, @David Zemdegs

    Thank you for posting in Microsoft Q&A forum.

    The "serviceconnectiontool error prereqs for this tool do not seem to be satisfied" error message indicates that the prerequisites for the Service Connection Tool are not met.

    According to Microsoft documentation, the prerequisites for the Service Connection Tool include having a service connection point configured for an offline, on-demand connection, running the tool from a command prompt as an administrator, having both the Visual C++ Redistributable x86 and x64 files installed, and having .NET version 4.6.2 or later installed.

    Please ensure that these prerequisites are met before running the tool again.

    References:


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Add comment".


  2. David Zemdegs 1,586 Reputation points
    2023-09-26T05:15:00.78+00:00

    If you look at the link on using the service connection tool you will see that it refers to:

    To download this component, see Visual C++ Redistributable Packages for Visual Studio 2013

    That is incorrect. We fixed the issue by also installing VC++ 2022.

    0 comments No comments