Unable to deploy the web app to the app service through local git source.

Gorthi Sai Sri Sindhuja 60 Reputation points


I have built a web app with Flask. I'm trying to host this web app on azure. I've created an app service resource and tried deploying the code through local git. Whenever I give push command, I'm getting the below error, I tried few solutions like git config --global pack.window 1, git config --global http.postBuffer 157286400, but nothing seems to work. Kindly help me with this***.***User's image

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
5,666 questions
{count} votes

1 answer

Sort by: Most helpful
  1. ajkuma 17,746 Reputation points Microsoft Employee

    @Gorthi Sai Sri Sindhuja ,

    Typically, this error can happen if you try to push a large git repository over HTTPS, I understand you have already changed the git configuration on the local machine to make the postBuffer bigger.

    Could you please try the following way and check if it makes any difference.
    git config --global http.postBuffer 524288000

    To isolate the issue further, please try these:

    1.    Verify if there is any firewall or proxy blocking the connection.

    2.    Try pushing the code from a different network or machine.

    0 comments No comments