text-davinci-003 is not working text rephrase and text spelling correction

Aiswarya Lakshmy 191 Reputation points
2023-09-14T08:04:48.3866667+00:00

Tried to connect to text-davinci-003 to rephrase and correct spelling by sending prompts to the API and processing the response.

But we are getting the below warning message while connecting,

"warning": "This model version is deprecated. Migrate before January 4, 2024 to avoid disruption of service. Learn more https://platform.openai.com/docs/deprecations"
Azure OpenAI Service
Azure OpenAI Service
An Azure service that provides access to OpenAI’s GPT-3 models with enterprise capabilities.
1,023 questions
0 comments No comments
{count} votes

Accepted answer
  1. AshokPeddakotla-MSFT 18,571 Reputation points
    2023-09-14T15:53:36.3433333+00:00

    Aiswarya Lakshmy Greetings!

    "warning": "This model version is deprecated. Migrate before January 4, 2024 to avoid disruption of service. Learn more https://platform.openai.com/docs/deprecations"

    You are seeing the warning due to Legacy Models.

    As mentioned here Azure OpenAI Service legacy models The following models are not available for new deployments beginning July 6, 2023. Deployments created prior to July 6, 2023 remain available to customers until July 5, 2024. We recommend customers migrate to the replacement models prior to the July 5, 2024 retirement.

    GPT-3.5

    The impacted GPT-3.5 models are the following. The replacement for the GPT-3.5 models is GPT-3.5 Turbo Instruct when that model becomes available.

    • text-davinci-002
    • text-davinci-003
    • code-davinci-002

    Hope this helps. Let me know if you have any further queries.


    If the response helped, please do click Accept Answer and Yes for was this answer helpful.

    Doing so would help other community members with similar issue identify the solution. I highly appreciate your contribution to the community.


0 additional answers

Sort by: Most helpful