Why is my Wordpress site switching between domains on Azure App Service?

massad 65 Reputation points
2023-10-16T02:57:03.1466667+00:00

I have set up my site on WordPress for Azure App Service and added my custom domains. In my case I have two custom domains:

clearblueionizer.com and www.clearblueionizer.com

mineralpools.com and www.mineralpools.com

The default domain for the app service is:

clearblueionizer.azurewebsites.net

In WordPress settings and options, it is showing the site domain as clearblueionizer.com which is what I want. It works almost everywhere, except on the link from the language maps and the link from the logo in the header. These both link to clearblueionizer.azurewebsites.net.

In the Custom Domains section in the admin, there is no option to set a default domain.

Just trying to figure out why some of these links are linking to the default (non-custom) domain because this is going to cause canonical issues with Google (and is unsightly for the user)

Thanks!

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,045 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. massad 65 Reputation points
    2023-10-16T16:19:43.3833333+00:00

    This ended up being an issue with the Polylang plugin. The fix was to resave each of the languages which cycled through the various domains. Once the correct domain was used, I left it alone.

    1 person found this answer helpful.