IP access restriction rule not working in Azure web app.

Vijayakumar Elumalai 80 Reputation points
2023-10-19T04:08:55.4666667+00:00

I have created a web app and deployed flask app in it. Also, i have created IP access restriction rule to enable access only to my local machine to access the web app url but still i am not able to access the URL though i have added rule with my local machine IP address. Do we need to use any specific IP details ? Please guide me on this. Thanks in advance!!!

Note: I have restricted all access by selecting "Deny" option in unmatched rule settings.

User's image

User's image

Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
7,031 questions
0 comments No comments
{count} votes

Accepted answer
  1. TP 78,976 Reputation points
    2023-10-19T04:21:43.67+00:00

    Hi Vijayakumar,

    You need to use your public IP address in the Allow rule instead of your local machine's private IP. You can find your public IP address by browsing to one of the public sites that show your address such as whatismyip.com, ip.me, and many others.

    Please click Accept Answer and upvote if the above was useful.

    Thanks.

    -TP


0 additional answers

Sort by: Most helpful