VM Failed to start - Pci Express Virtual Port Error "Item not found." (0x80070490) when powering on (Discrete Device Assignment)

2023-10-24T20:40:52.41+00:00
Good day everybody,

I have the problem that after assigning a Tesla M60 card my VM no longer starts. Unfortunately I can't find anything about it, have any ideas? Picture attached.

BS is Server2022

Nvidia Tesla M60 card

I am thankful for every help!

Addendum, the picture must have been torn up:

[window title]

Connecting to virtual machines

[Main Instruction]

Application error attempting to change the status of “101052-DNW-TS02”.

[Contents]

Error starting “101052-DNW-TS02”.

Virtual Pci Express Port (Instance ID: 912943B4-6C50-4E64-9118-21879602CA56): Power on error: Item not found..

[Extended information]

Failed to start 101052-DNW-TS02 (VM ID 5ABCAAF3-0D3F-415D-BCDD-FD7DF837458C).

"101052-DNW-TS02" Pci Express Virtual Port (Instance ID 912943B4-6C50-4E64-9118-21879602CA56): Error "Item not found." (0x80070490) when powering on (Virtual Machine ID: 5ABCAAF3-0D3F- 415D-BCDD-FD7DF837458C).

The PCI Express device 'PCIP\VEN_10DE&DEV_13F2&SUBSYS_113A10DE&REV_A1\6&17F903&0&00400019', which is incompatible with the currently set Group Policy, could not be mapped. For more information, see HyperV\RequireSecureDeviceAssignment and HyperV\RequireSupportedDeviceAssignment.
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
12,410 questions
Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,597 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. 2023-11-03T11:51:41.7166667+00:00

    Got it, solved the Problem with this:

    UPDATE:

    I managed to successfully boot the VM with the graphics card by adding the following to the registery and typing [bcdedit /set hypervisoriommupolicy enable] in Powershell.

    Registry key path (create it if not present): HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\HyperV

    Registry values:
    RequireSecureDeviceAssignment = 0 (REG_DWORD)
    RequireSupportedDeviceAssignment = 0 (REG_DWORD)

    Source: https://github.com/MicrosoftDocs/windowsserverdocs/issues/3083#issuecomment-578502515

    However, I get a code 43 after installing the latest driver for the RX 590. I have never seen this happen on an AMD card. I tried installing an older driver and the Code 43 still persists.

    https://www.reddit.com/r/HyperV/comments/elxkiv/hyper_v_dda_windows_server_2019/

    0 comments No comments