Automl fails to prep data

Kush Shah 0 Reputation points

I have a dataset that is mostly curated of ~30 features (25 decimal 5 numeric) and about 40k rows. In azure ml studio, In a Jupyter notebook from the UI I am able to run a random forest model on this data as expected but when I try to run this in automl with featurization enabled or disabled and with feature type set to auto orspecified the job fails or runs with "setting up the run" status till it is timed out. Below is the error from the child job:

Below is from the raw JSON:

error": {
        "error": {
            "code": "System",
            "severity": null,
            "message": "",
            "messageFormat": "Failed to get data from DataPrep. Exception Type: <class 'NotImplementedError'>",
            "messageParameters": {},
            "referenceCode": "prepare",
            "detailsUri": "",
            "target": null,
            "details": [],
            "innerError": null,
            "debugInfo": null,
            "additionalInfo": null


Below is from the log:

File "/azureml-envs/azureml-automl/lib/python3.8/site-packages/azureml/dataprep/api/", line 90, in add_step
    raise NotImplementedError
azureml.train.automl.exceptions.ClientException: ClientException:
	InnerException: NotImplementedError: 
    "error": {
        "code": "System",
        "message": "",
        "reference_code": "prepare"

I thought it was an issue with my data but I was able to get expected results running this locally and within the notebook in the studio. I tried to create a new compute instance as well but the same error persisted. Is there a step I am missing to setup a run on automl? I followed the steps in the UI as mentioned here:

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,232 questions
{count} votes