Exporting VM in Hyper-V Server 2019 - Exported VM Files are missing, Cannot be imported and VM no longer bootable

TFS 0 Reputation points

I have been having some issues with a VM hosted on a 3 node cluster. The main issue was after patching and rebooting the Hyper-V hosts and the guests, (all of them were patched and rebooted successfully) but afterward the event log for one particular VM was filled with the 1069 error, something about it not being able to find the resource configuration file for VM XYZ - all other VMs which are also hosted on the same storage and clustered hosts work fine, it was just this 1 VM.

Despite this, the VM was up and running on node 1 and was all good, though there were errors coming from node 2 for that specific VM and I am assuming that when the reboots happened for patching that node 1 attempted to shift the VM to node 2, but was unable to because of error 1069 and once node 1 came back online, it brought the VM back online. I checked the roles in Failover cluster manager and noticed that this VM was not configured to be clustered, attempted to turn this on and it errored out.

I found a few articles online which described similar problems/errors to what I was seeing but they were all slightly different circumstances where the users had tried different things to fix it, but that ultimately made things worse. However, using these articles, I was able to piece together that basically I just needed to re-register the VM with the CSV resources and to do this, you simply export and import the VM.
I planned on exporting the VM from node 1 and importing it to node 2 as node 2 was the one that had the error, so was hoping that doing this, it would clear up any issues with accessing the CSV or that particular configuration file on the CSV (I had confirmed that all nodes had access to the CSV but was unable to find the config file it was referencing in the error message when navigating there myself via Explorer).

I followed the MS article for exporting and importing VMs which isn't very complex and would be hard to mess up: https://learn.microsoft.com/en-us/windows-server/virtualization/hyper-v/deploy/export-and-import-virtual-machines

I logged into the VM and shut it down, then I went to Hyper-V manager, right clicked the VM > Export.
I selected storage on one of our clusters, took note of where it was and even copy+pasted the path from the dialogue box into a notepad to be safe. I then hit OK and the box disappeared but nothing else showed up anywhere to denote any kind of progress or failure/success of the attempted operation (where can I see this? I'm used to VMware where it displays all actions down the bottom and their progress. This is the first place I've worked that uses Hyper-V and I'm starting to see why).
No extra files have shown up at the location and when attempting to Import the VM to any of the 3 nodes/hosts it doesn't show up as one of the available VMs and I can no longer boot the VM either.

What happened to my VM? What are my best options for restoring this VM?

The VM files still exist exactly where they were, however the exported VM files don't appear to exist and aren't selectable as an importable VM. The VM still shows up in the list of VMs that are on node 1 but I can't boot it.
How do I fix this mess?

Happy to provide more info or screenshots as necessary but not really sure what would help and would obviously have to censor specifics.


A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,374 questions
0 comments No comments
{count} votes

1 answer

Sort by: Most helpful
  1. TFS 0 Reputation points

    I figured it out but had to drill down into the file structure to find the VM files in order to import them, this was not the exact location I chose when I exported the VM and was not explained in the MS learn article I was referencing - I am not sure why this happened but glad I was able to figure it out, find it and import it successfully. My other errors in the FCM Roles GUI have also cleared and everything seems to be working as expected.
    This is not the first time I've had issues with MS Learn pages where they ommit small but important details, making you do some guess work for something that was explained poorly or not at all.

    0 comments No comments