Azure Function App/App Service unable to send logs to storage account on VNET

Taal, Michelle SITI-PTIY/FHA 0 Reputation points

Deploying an Azure Function or App Service inside a VNET makes it difficult to connect with storage accounts, leading to plenty
"Storage access failed. Storage volume is currently in R/O mode" errors. We ran into similar issues as other people with deploying the application code to file share, but were able to successfully deploy this using the regularly references solution of setting "WEBSITE_CONTENTOVERVNET"=1. However, have been unable to have such luck with enabling the App Service Logs to be able to review the log stream.

We have tried several options, including the one references here: But regardless of how we configure our storage account we seem unable to get beyond this "Storage access failed. Storage volume is currently in R/O mode" error. We have tried:

  • storage accounts with no networking rules (same and different regions)
  • storage accounts in the same subnet (same and different regions)
  • storage accounts in the same vnet but different subnets (same and different regions)

(we are unable to use service endpoints due to company policies)

When inspecting the storage account logs of these experiments we only find 404 errors for missing $logs or $blobchangefeed, or the proper path expected for the app service logs. Sometimes even all 200 responses. Where is this error coming from, and how can we get around it?

Azure Functions
Azure Functions
An Azure service that provides an event-driven serverless compute platform.
3,681 questions
Azure Storage Accounts
Azure Storage Accounts
Globally unique resources that provide access to data management services and serve as the parent namespace for the services.
2,292 questions
Azure App Service
Azure App Service
Azure App Service is a service used to create and deploy scalable, mission-critical web apps.
6,014 questions
{count} votes

1 answer

Sort by: Most helpful
  1. MikeUrnun 8,336 Reputation points

    Hello @Taal, Michelle SITI-PTIY/FHA - Sorry for the delay. The connectivity issue & errors that you've been observing seem related to a known issue around how the storage account needs to be publicly accessible at the time of Function App deployment. There's an open feedback item here: Deploy function app and storage account with network restrictions which states the workaround being:

    Only work around is to create a policy exemption, create Storage Account without network restrctions, deploy Function App.

    I hope this helps & provides clarity on the matter.

    Please "Accept Answer" if the answer is helpful so that others in the community may benefit from your experience.

    0 comments No comments