Azure VNET cannot resolve a specific domain name

gerard bastos 0 Reputation points

I currently Have an Azure VNET which cannot resolve my Dynamics 365 domain name when I try to query the API.

This VNET is setup with private DNS zones for an azure APIM instance and for my test, I allowed all ports in the associated Network security group.

I have a VM within this VNET And I am trying to query the Dynamics 365 API from it (using a powershell script).

The domain name of this endpoint is When I try to query this api from my VM am getting the following error:

The remote name could not be resolved: ''

The strange thing is that When I try to query this API from my laptop (outside this VM), it is working fine. I have also tried to query other APis like the like from my VM and it worked fine, I am only experiencing this issue with my Dynamics domain name.

What could i do to fix it ?

Thank you

Azure Virtual Network
Azure Virtual Network
An Azure networking service that is used to provision private networks and optionally to connect to on-premises datacenters.
1,829 questions
{count} votes