Visual Studio fails to install. The bootstrapper just disappears.

Don Ferguson 0 Reputation points

On one of my systems I can't get any version of Visual Studio to install. The bootstrapper program just disappears. My primary focus is to get Visual Studio 2019 Professional to reinstall. When I had it opened and tried to update it on close I got a message saying that something went wrong.

I have subsequently run the cleanup utility and removed the installation folder. But nothing works. It just shows the window getting things ready, downloading, installing, and then it just disappears without further message. I even opened a VS support chat and the person on the other end was not able to resolve the issue. He suggested that I open a ticket hear. I have spent countless hours on this, I have tried many solutions posted online and nothing changes this behavior. I need some real help on resolving this issue. Please note it works fine on another host with a system configured exactly the same way. Yes it has a VPN and Windows defender installed on it. Both systems do, the one that works and the one that doesn't. I cannot control that fact due to corporate assigned group policies.

Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
900 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Don Ferguson 0 Reputation points
    0 comments No comments

  2. Tianyu Sun-MSFT 22,346 Reputation points Microsoft Vendor

    Hello @Don Ferguson,

    Glad to hear that you can successfully install VS.

    "The bootstrapper just disappears", this issue appears at the very beginning when installing VS and generally, it’s caused by some system configurations.

    Changing of Windows Registry keys, previous installed Visual Studio/cache files weren’t removed correctly or completely, missing some necessary Windows system files, all may lead to this issue. Cleaning cache(including the Registry keys) or installing VS from scratch(download a new setup file and put it into the root of the C drive and install again) may fix this issue.

    Anyway, thanks for sharing the solution here, feel free to contact us if you have any further concerns.

    Kind Regards,


    If the answer is the right solution, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments