Setting response header "Set-Cookie" with "SameSite=None;Secure" on Edge was blocked due to user preferences

Gu, Jay 0 Reputation points

I set in the response header "Set-Cookie" with "SameSite=None;Secure" for cross-domain cookies which works well on Chrome. But I find the cookie doesn't work on Edge Version 119.0.2151.58 on Win 11, and the Edge gives an error on the response header "Set-Cookie", it says "This attempt to set a cookie via a Set-Cookie header was blocked due to user preferences". I disabled the option "Block third-party cookies" and added my domain including the third party cookies in the site in the cookie allow list. But these didn't help. It's weird that I tried on different machines with the same Edge Version 119.0.2151.58 including the same cookie settings and the same OS Win 11, the cookies worked on some of them but didn't work on the others. Could someone please give me some hits about how to fix this issue? Thanks!

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
1,906 questions
{count} votes

1 answer

Sort by: Most helpful
  1. ShiJieLi-MSFT 5,526 Reputation points Microsoft Vendor

    Hi @Gu, Jay,

    Thanks for the information. This issue is not a known issue and seems to be machine-specific, so some logs may be necessary for us to troubleshoot the problem. Since this issue is spreading on your organization devices, I would suggest you create a support ticket (Support for business) to contact support engineers for log analysis.

    Thanks for your understanding!

    If the answer is helpful, please click "Accept Answer" and kindly upvote it. If you have extra questions about this answer, please click "Comment".

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    Best Regards,

    Shijie Li

    0 comments No comments