Cannot login to my personal Azure account because it is linked to an organization

Kilian 0 Reputation points
2023-11-18T10:14:47.2566667+00:00

I'm trying to access my free personal Azure account to manage it, but when I attempt to log in, it's asking for a 2FA code sent to the Microsoft Authenticator app with a message similar to the following:

"Approve the login request Open the Authenticator app and enter the number displayed to log in."

I'm not receiving that code, and I believe it's because, for some reason, it's trying to authenticate against a company I worked with months ago, as their logo appears on that screen. I'm not sure why my personal account has become linked to the business account, but I would like to unlink them, and I don't know how to do that. I have no relation with that company anymore.

It is not something about cookies or my browser I tried login in with a different browsers and also with "Incognito/InPrivate Mode".

NOTE: login for other Microsoft services also ask me to login with Microsoft Authenticator app, and they work because they use my personal account (no logo of the company is shown there).

Microsoft Authenticator
Microsoft Authenticator
A Microsoft app for iOS and Android devices that enables authentication with two-factor verification, phone sign-in, and code generation.
6,105 questions
0 comments No comments
{count} votes